Elementor выдаёт ошибку при нажатии на Viber

Вышла версия плагина 2.9.11 Elementor для WordPress. Сделал ручное обновление 04.06.2020. Начал редактировать единственную страницу на одном сайте, там только она и была, одна  рекламная страница.

По окончании, начал проверять корректность работы якорей, ссылок, текстовку, и рабочее состояние телефонных номеров. При нажатии которых открывается приложение в смартфоне с набранным номером. Мобильные номера отработали всё чётко, а Viber вместо открытия приложения, начал перегружать страницу сайта. Курсором навожу на номер, смотрю, показывается url сайта, вместо необходимого viber://add?number=333333333

Снова открыл редактор Элементора, всё правильно и корректно прописано. Никаких урлов сайта,  только html ссылка на вайбер с номером. Сохранил.  И снова такая же дрянь вылезла.

Ну не первый раз же это делаю….

Смотрю исходный код  страницы, вижу начинается < a href>  и всё. Бред какой то. Перед этим установил плагин с бесплатным сертификатом SSL, подумал может он глюк дал. Но нет, ничего не обнаружил. Залез в CPanel, там ответов не нашел.

Обновил версию WordPress заново, такая же беда.

Ок. Думаю надо попробовать откатить к предыдущей версии плагина. Разработчики предусмотрели это,  я откатил до версии 2.9.8. И все заработало как надо.

Перед этим сохранил макет страницы себе на ПК.
Чтобы вернуть предыдущую версию Elementor на вордпрессе, смотрите  вкладку Элементор с левой стороны, открыть “Инструменты”, и вкладка “Контроль версий”.

Не знаю, есть ли этот глюк  в Pro версии, но сам пользуюсь бесплатной.

5 thoughts on “Elementor выдаёт ошибку при нажатии на Viber

  • 3 июля, 2020 at 10:31 пп
    Permalink

    бесплатная версия 2.9.9 до сих пор с этим багом.
    они его фиксить не будут или как? не встречалась эта проблема на форумах?
    мне кажется это они специально, чтобы на про переходили

    Reply
    • 4 июля, 2020 at 10:06 дп
      Permalink

      Согласен, есть ощущение, что принуждают на переход в платную версию. Увы, форумы не мониторил по этому вопросу. Думаю, что в скором времени, плагин станет полностью платным,с минимальным тарифом.

      Reply
  • 12 июля, 2020 at 2:56 пп
    Permalink

    спасибо тебе, добрый человек )))

    Reply
  • 26 июля, 2020 at 1:24 дп
    Permalink

    Разработчики знают об данной проблеме, и предлагают как решение – _https://developers.elementor.com/uri-protocols-handling-update/
    Сам столкнулся сегодня с данной проблемой, но слава богу у них есть комьюнити на гитхабе. И так же при наличии про версии нечего не меняется.

    Reply
  • 26 июля, 2020 at 7:45 дп
    Permalink

    Откатить к предыдущей версии не проблема. Подождем до 3.0.0.

    Reply

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *